EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: Question about Rebuilding in the correct path of zip file  (Read 5395 times)

pomate

  • Karma: 0
  • Offline Offline
  • Posts: 3
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 17.0 Firefox 17.0
    • View Profile

Hi to all people in the forum,

I need some help with Rebuilder, when I rebuild Mame Roms they are rezipped but with a subdirectory within the zip file.
For example 1941.zip has internally a folder .\1941\ containing new added roms.

When this happens zip files need to be reprocessed with Scanner or Romcenter to be fixed.

I've searched in Rebuilder Advanced Options and in the forums, but I've not found a solution.

In your experience is there a way to Rebuild and Rezip directly roms in the correct path in the zip file?

Thanks for any info

Pomate
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 112
  • Offline Offline
  • Posts: 3284
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 21.0.1180.89 Chrome 21.0.1180.89
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #1 on: 23 September 2012, 14:23 »

If you got subfolders in zips then you got definetly something wrong in your rebuilder configuration. MAME sets don't use subfolders (i.e. there are no specifications for such things in the -listxml database) and by default the rebuilder does not magically add them.

You should check your rebuilder advanced options if you got something specified in "dest. prestring" option...which allows something like this. Nothing should be listed there and the option should be unticked.

(assuming you're using a direct import from the official MAME binary...and no 3rd party modified dat which may do magic with setsubfolders or rebuildto elements...)

You may want to create a new mame exe based profile with clean default options.
« Last Edit: 23 September 2012, 18:27 by Roman »
Logged

pomate

  • Karma: 0
  • Offline Offline
  • Posts: 3
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 17.0 Firefox 17.0
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #2 on: 29 September 2012, 09:23 »

Hi, thanks for your advice, but I've checked and "Dest. prestring" option is unchecked.
I did't change anything after the installation of clrmame, do you suggest me to clean all registry entries related to clrmame and try again?
I'm building the profile starting from MameUI32, should I use a Mame Binary? But I don't think this is the problem

I will now check with another Rom Manager (Romulus) if I see the same subfolders after rebuilding, It's very strange Iìm the only one to have this problem.

I'll perform some more checks and then report back, thanks

Mauro
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 112
  • Offline Offline
  • Posts: 3284
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 22.0.1229.79 Chrome 22.0.1229.79
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #3 on: 29 September 2012, 11:50 »

You can try to send me your cmpro.ini file, the belonging *.cmp file (cmpro settings folder) for the used profile and some example files so I can create your environment somehow.

..and yes..you seem to be the only one :)
I did lots of tests and was not able to reproduce this at all.
Logged

pomate

  • Karma: 0
  • Offline Offline
  • Posts: 3
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 26.0 Firefox 26.0
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #4 on: 15 December 2013, 15:42 »

Hi, sorry but i do not undestand comments about *.ini and .cmp files,
I've perfomed many installation on different clean systems and the result is always the same: clrmamepro rebuild function puts romfiles in subfolders structures into the zip files (and the name of the subfolder in zips, is the name of the set for the added romfiles).

So my guess is that what you say about .xml files could be due to the way MameUi32/64 produce set info imported by clrmame. Is it so?

The ones who say they cannot reproduce, how are you loading Mame profiles in Clrmamepro? [just for my understanding]
And where are the rom files in the zip file when you use Rebuild? [are they not in subfolders into the zip file?]

Thanks for your info, I hope to solve this problem somehow.
P.

PS: What about an option for path correction in Clrmamepro in the scan options for compressed files, like the one Romcenter and Romulus have?

Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 112
  • Offline Offline
  • Posts: 3284
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 31.0.1650.63 Chrome 31.0.1650.63
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #5 on: 15 December 2013, 21:28 »

The comment about *.ini and *.cmp files simply means you should send me a copy of your cmpro installation...I only need the cmpro.ini file and the *.cmp file from the cmpro settings folder which belongs to the profile you're using.

Cmpro does not include subfolders structures into zipfiles as long as the used datfile does not use them...and MAME never did such a thing.

There is no need for "an option for path correction in Clrmamepro", since cmpro already complains if you got your files stored in wrong subpaths or subpaths inside archives.

Again...nobody but you ever mentioned such a problem. As long as you can't provide me additional information like screenshots showing your problem or the files mentioned above, I can't help you.

The normal way to produce a profile for MAME within cmpro is simple: Go to the profiler, click create, let the Filename point to your official MAME exe file, be sure Emulator says "MAME" and enter a Description...that's it...hit Create Profile and after returning to the main screen, double click the created profile to load it....There will be some prompts appearing during loading, you can hit always "Yes for all" ...to keep it simple...
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 112
  • Offline Offline
  • Posts: 3284
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 31.0.1650.63 Chrome 31.0.1650.63
    • View Profile
Re: Question about Rebuilding in the correct path of zip file
« Reply #6 on: 21 December 2013, 19:26 »

Thanks for sending in the files....
I tried to rebuild your scenario as best as possible but still no luck to repeat your issue.

Attached is an example screenshot showing the rebuilt zipfile (using your configuration) which only contains the roms, no subfolders.

So...maybe you show me some screenshots from your system where you show me what your problem is...maybe we're talking about totally different things....
Logged
Pages: [1]   Go Up
 

Page created in 0.172 seconds with 19 queries.

anything
anything