EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: Error with sysdefault paths  (Read 2265 times)

0815_argh

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 55.0.2883.87 Chrome 55.0.2883.87
    • View Profile
Error with sysdefault paths
« on: 01 February 2017, 07:55 »

Hi,

I'm trying to set up a softwarelist scan in Mame 0.182. I set all the sysdefault paths (unchecked everything BIOS and mechanical as I'm unsure which paths go where) but the [SOFT]-Paths are set correctly. Clrmamepro gives me the following error:



I can't find any [SOFT]-path which isn't unique. How can I check which path(s) is/are affected? Thanks!
« Last Edit: 01 February 2017, 07:55 by 0815_argh »
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 78
  • Offline Offline
  • Posts: 2634
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 56.0.2924.76 Chrome 56.0.2924.76
    • View Profile
Re: Error with sysdefault paths
« Reply #1 on: 01 February 2017, 08:15 »

Send me the belonging cmpro's settings folder *.cmp file (for your profile)

From the screenshot it looks like there is one empty one? (There is an empty line above the ....)
....or enable BIOS/MECHANICAL and set them to some folder(s)

Maybe a better way to use software lists is to not use the mixed mode (Software lists/standard mame) but standalone profiles for each list
« Last Edit: 01 February 2017, 08:16 by Roman »
Logged

0815_argh

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 55.0.2883.87 Chrome 55.0.2883.87
    • View Profile
Re: Error with sysdefault paths
« Reply #2 on: 01 February 2017, 21:21 »

Here is the link to the .cmp-file:

http://www.file-upload.net/download-12283061/mameui64-0.182.cmp.html


I set every rompath I wasnt sure about to my main MAME roms directory. Paths with [SOFT] are unique tho (except for one, which points to MAME\roms but is unchecked).
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 78
  • Offline Offline
  • Posts: 2634
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 56.0.2924.87 Chrome 56.0.2924.87
    • View Profile
Re: Error with sysdefault paths
« Reply #3 on: 02 February 2017, 13:46 »

thanks, I will have a look at it
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 78
  • Offline Offline
  • Posts: 2634
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 56.0.2924.87 Chrome 56.0.2924.87
    • View Profile
Re: Error with sysdefault paths
« Reply #4 on: 03 February 2017, 21:01 »

ok yeah....a bug is hiding the real problem:

---------------------------
Bad System-Default-Paths
---------------------------
You're using SysDefPath options and at least one software list path is not unique!
Softwarelist paths have to be unique and cannot be shared with others.

The paths for the following systems are affected:


- [SOFT] Sord M5 cartridges -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_cart\
- [SOFT] Sord M5 cassettes -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_cass\
- [SOFT] Sord m5 diskettes -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_flop\
- [SOFT] Thomson MO5 cartridges -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_cart\
- [SOFT] Thomson MO5 cassettes -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_cass\
- [SOFT] Thomson MO5 floppy disks -> G:\_MAME-0.182-Softwarelists\MAME 0.182 Software List ROMs (merged)\mo5_flop\



ah yeah and the fixed version is here:

http://mamedev.emulab.it/clrmamepro/binaries/cmpro20170203.rar
« Last Edit: 03 February 2017, 21:11 by Roman »
Logged

0815_argh

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 56.0.2924.87 Chrome 56.0.2924.87
    • View Profile
Re: Error with sysdefault paths
« Reply #5 on: 04 February 2017, 23:59 »

Thanks a lot, I didn't see that. The download link doesn't work tho :)
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 78
  • Offline Offline
  • Posts: 2634
  • OS:
  • Mac OS X Mac OS X
  • Browser:
  • Safari 10.0 Safari 10.0
    • View Profile
Re: Error with sysdefault paths
« Reply #6 on: 05 February 2017, 08:00 »

link works fine here....
Logged

0815_argh

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 56.0.2924.87 Chrome 56.0.2924.87
    • View Profile
Re: Error with sysdefault paths
« Reply #7 on: 05 February 2017, 12:29 »

Works for me now, too. Strange. Thanks again!
Logged
Pages: [1]   Go Up
 

Page created in 0.13 seconds with 22 queries.