EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: Profiler slow to load  (Read 10491 times)

Terra_Cresta

  • Karma: 0
  • Offline Offline
  • Posts: 17
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Firefox 3.6.12 Firefox 3.6.12
    • View Profile
    • ROM Shepherd
Profiler slow to load
« on: 27 November 2010, 17:53 »

On initial application start-up and periodically during use the profiler takes an inordinate amount of time to complete the "looking for datfiles" process. Admittedly, I have quite a few datfiles but for the most part this seems to be cached and seems to complete quite quickly.

It was pretty slow pre 3.137 but I thought it was just due to the sheer number of datfiles present. 3.137 seems to *add* something which makes the process slower taking up to four minutes to complete the "looking for datfiles" bit.

Is it a case of - to quote Bruce Hornsby - "That's just the way it is"?
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Mac OS X Mac OS X
  • Browser:
  • Safari 5.0.2 Safari 5.0.2
    • View Profile
Re: Profiler slow to load
« Reply #1 on: 27 November 2010, 20:11 »

actually nothing changed for ages in the profiler. can you maybe send me your setup in a compressed form somehow?
maybe something changed on your system? a going nuts virusscanner? some self created settings files? will do some checks next week but would be great to have your config setup.
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Chrome 7.0.517.44 Chrome 7.0.517.44
    • View Profile
Re: Profiler slow to load
« Reply #2 on: 29 November 2010, 20:15 »

It's quick as always here....so....any chance to send me your setup?
Logged

Terra_Cresta

  • Karma: 0
  • Offline Offline
  • Posts: 17
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Firefox 3.6.12 Firefox 3.6.12
    • View Profile
    • ROM Shepherd
Re: Profiler slow to load
« Reply #3 on: 29 November 2010, 22:06 »

Hang in there :) I'll post tomorrow morning GMT. It's a 264Mb RAR... just uploading to a file sharing host.

http://www.sendspace.com/file/ynhy3a
« Last Edit: 30 November 2010, 07:13 by Terra_Cresta »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Chrome 7.0.517.44 Chrome 7.0.517.44
    • View Profile
Re: Profiler slow to load
« Reply #4 on: 30 November 2010, 19:07 »

thanks....downloaded the archive and only decompressed the datfile and settings folder into a new instance of cmpro 3.137....started it and it took 4 seconds(!) to load 2638 datfiles and settings files...

....will do the same with your full archive later on.....but it seems to be your system at the moment....
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Chrome 7.0.517.44 Chrome 7.0.517.44
    • View Profile
Re: Profiler slow to load
« Reply #5 on: 30 November 2010, 19:48 »

and now to your full archive:

cmpro64.exe (3.137): 5 seconds
cmpro.exe (3.134b): 5 seconds
cmpro_3.89a: 2 min 1 second
cmpro_3.88: 1 min 59 seconds

well, as you can see it's fast enough for the current version...I think 5 seconds to process ~2600 dats and ~2600 settings files is ok.

There is no reason to keep such old (4.5 years!) cmpro versions like 3.89a or 3.88.


by the way, testing system was a 64bit Windows 7 on a C2D 6600 cpu with 4GB...and a fast HD....nothing really up2date l33t pc...
« Last Edit: 30 November 2010, 19:49 by Roman »
Logged

Terra_Cresta

  • Karma: 0
  • Offline Offline
  • Posts: 17
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Firefox 3.6.12 Firefox 3.6.12
    • View Profile
    • ROM Shepherd
Re: Profiler slow to load
« Reply #6 on: 30 November 2010, 21:40 »

If it can help anyone AV software seemed to be the cause. Once the CMPro folder was excluded from scans profiler loads in just a few seconds. :)

Cheers Boss.
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Chrome 7.0.517.44 Chrome 7.0.517.44
    • View Profile
Re: Profiler slow to load
« Reply #7 on: 30 November 2010, 21:41 »

So....if you want to have a speedy profiler, add cmpro's settings and datfile folder to the virusscanner's exclusion list....they contain only text/xml files anyway....
Logged

trebelez

  • Karma: 0
  • Offline Offline
  • Posts: 6
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 5.0 Firefox 5.0
    • View Profile
Re: Profiler slow to load
« Reply #8 on: 04 August 2011, 16:12 »

I know this thread is old, but I'm having the same problem.

  • It happens at the first opening AND after a looong time clrmamepro remained closed
  • It opens instantly after I closed it
  • I have a lot less DATs than TC (I'd attached the htm report.)
  • I added the complete clrmamepro folder to avast IS exclusion list (I always used the EXE to install it and to update it)

Maybe a fragmented disk C is causing this? (I'm just guessing)
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows 7 Windows 7
  • Browser:
  • Chrome 13.0.782.107 Chrome 13.0.782.107
    • View Profile
Re: Profiler slow to load
« Reply #9 on: 04 August 2011, 19:23 »

Turn off virusscanners completly (for a test) and be sure you didn't use 3rd party tools to mass-create cmpro profiles...
Last time I've checked it it loaded something >3000 profiles within seconds...
all I can say for now...
« Last Edit: 04 August 2011, 19:28 by Roman »
Logged
Pages: [1]   Go Up
 

Page created in 0.186 seconds with 20 queries.

anything