EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit  (Read 885 times)

Spydey

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.77 Chrome 91.0.4472.77
    • View Profile
Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« on: 08 June 2021, 16:12 »

Hi Roman,

I have an issue and perhaps you know what is happening.
In the past I have used ClrMamePro extensively to manage my Mame Split Rom set. I don't use SoftwareLists and everything is in one big folder. Both ClrMamePro and the Roms are on an external USB Drive. Recently I upgraded my PC and reconnected this drive with the same Drive letter to my new PC.

Fast forward to now when a new version of Mame (.232) has been made available. I tried to rescan my set and the scan works without incident. But when I try to fix some roms ClrMamePro crashes without any further message. Especially a fix with the "unneeded" option creates the crash.
I did find a small Windows crash file with a c0000409 0x7 (FAST_FAIL_FATAL_APP_CRASH) error, which I have included.

Can you determine what happened? Or does this mean there's something wrong with my computer?

Regards!
Spydey
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 102
  • Offline Offline
  • Posts: 3064
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.77 Chrome 91.0.4472.77
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #1 on: 08 June 2021, 16:25 »

A crash when fixing files was not reported yet.

Hard to say what is happening. The most likely scenario is a corrupt archive file so that a 3rd party lib (zip / 7z / rar) has a problem when modifying the corrupt archive.
So the best thing to do is to enable "Ask before fixing" option and don't use the "yes to all" / "no to all" prompts but single click through the messages. By doing that you might be able to find out which set is creating the problem.
Or try to limit the amout of data which you want to scan. For example try less rompaths with less files....so a bit trial and error to find out where exactly the problem is.

Also of interest is your setup: 32/64 bit version of cmpro, latest version?, windows version?. Special settings set in cmpro? (e.g. you can send me your used *.cmp file from cmpro's settings folder and cmpro.ini).

More unlikely is bad RAM (or wrong RAM timing) which can cause all kind of weird effects....but as I said...pretty unlikely.
Logged

Spydey

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.77 Chrome 91.0.4472.77
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #2 on: 09 June 2021, 13:58 »

I have included the current cmpro.ini. I am running a 64-bits version 4.041 of ClrMamePro (I also tried the 32-bits version, with identical results).
My Windows is currently a Windows 10 Pro 21H1 with OS build 19043.1023
The Profiler is generated as based on the latest Mame.exe (64-bits) version .232
I recently performed a Windows Memory Test on this system and this has resulted in no errors.

As for an example. I currently have an unneeded file in the rom "19xx.zip" (dl-1425.bin). If I reply "Yes" to the fixing of this rom ClrMamePro crashes. If I manually delete the file from the zip (with 7-zip) everything afterwards works fine.

If I manually move this file back again into the zip I can see it is different based on the Characteristics (existing files: UTF8, new file: NTFS) and it crashes again afterwards during the fixing. I have tried both 7zip as winrar to re-add the file and recreate this error.
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 102
  • Offline Offline
  • Posts: 3064
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.77 Chrome 91.0.4472.77
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #3 on: 09 June 2021, 14:09 »

OS and versions all sound good.

Removing files definetly doesn't crash here (and noone else reported it and believe me...such a problem would have popped up very very early :)).
If you are able to reproduce the error (and it seems you are), please send me the zip file in question somehow.


Besides of looking at the archive, you may want to toggle making backups (Settings -> Make backups to folder). Maybe it tries to add the file it wants to delete to a corrupt archive in backup....
« Last Edit: 09 June 2021, 14:38 by Roman »
Logged

Spydey

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.77 Chrome 91.0.4472.77
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #4 on: 12 June 2021, 11:34 »

Hi Roman,

Disabling the backup didn't have any effect. I send you a PM with a zipfile where this issue occurs.

Regards!
Spydey
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 102
  • Offline Offline
  • Posts: 3064
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.101 Chrome 91.0.4472.101
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #5 on: 12 June 2021, 11:55 »

thanks, I will have a look
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 102
  • Offline Offline
  • Posts: 3064
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.101 Chrome 91.0.4472.101
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #6 on: 12 June 2021, 13:00 »

As I've mentioned in the PM, it works fine here. Cloned your environment and the example file pops up for fixing and clicking yes works flawlessly.

You've mentioned that you took the hd from an older system so I though it might be related to user access rights somehow. You've said something about "it was utf8 then ntfs". Can you go a bit into details here please? Because utf8 isn't a filesystem format like ntfs. Any information about the hd (which format), possible user access rights etc could be helpful.
Also you may want to turn off virusscanners and other 3rd party tools for a quick test only. Maybe copying some of the 'crashing files' on a different harddisk gives some positive or negative feedback...
"
I've played a bit with access rights on files (e.g. not allowing write operations etc) but even then it doesn't crash and simply shows messages like Can't remove files from: E:\Emulation\Roms\Mame\48in1.zip etc...

So...everything's fine here :( ...and noone else reported such a thing yet (and removing files it one of the most common things)...so I somehow have your taken-over-hd in mind...but currently no idea what's causing a crash.


If you google the error message you will find things like:
https://social.technet.microsoft.com/Forums/en-US/307ccfcb-a815-4a82-9c66-d901990708f4/uev-causes-explorerexe-crash?forum=mdopuev

so..that's an example where Microsoft UE-V (User Experience Virtualization) causes crashes even in its own explorer...so that's why I'm asking for possible 3rd party tools interfearing..
So...any synching tool running on your PC?
« Last Edit: 12 June 2021, 13:04 by Roman »
Logged

Spydey

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.114 Chrome 91.0.4472.114
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #7 on: 24 June 2021, 15:03 »

Hi,

I just wanted to confirm that my issue was solved. After moving all files to a new external drive with a different type of connection the same files were scanned and adapted by ClrMamePro succesfully again.

Thank you Roman for your patience and quick replies and help in investigating this issue!
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 102
  • Offline Offline
  • Posts: 3064
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 91.0.4472.114 Chrome 91.0.4472.114
    • View Profile
Re: Clrmamepro dumps - 0x7 fast_fail_fatal_app_exit
« Reply #8 on: 25 June 2021, 06:52 »

Thanks for testing and digging. Interesting thing though....Looks like Windows System libs are crashing here...might be worth to check it a bit more deeply when I find some time and report it to MS :)
Logged
Pages: [1]   Go Up
 

Page created in 0.094 seconds with 20 queries.