EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: wrong SysDefPath error while Scanner, but it wasn't fixed...?  (Read 453 times)

llagos

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 33
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.90 Chrome 77.0.3865.90
    • View Profile

Hi,
Quick question. I just did a full Scanner, with all Check&Fix ON.. later in the logfile I can see several messages such as this:

Astro Chase [softwarelist: a800 - folder: achase - size: 16kb]
wrong SysDefPath: achase [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\a800\]

I do have 2 zips but are different in their content, although it seems only the filename is different:

$ ls -l a800/achase.zip
-rwxrwx---+ 1 llagos None 10087 Jun 15 11:10 a800/achase.zip
$ ls -l standard/achase*
-r-xr-x---+ 1 llagos None 10090 Mar  8  2017 standard/achase.zip
$ unzip -l a800/achase.zip
Archive:  a800/achase.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
    16384  12-24-1996 23:32   astro chase (first star software)(1982).rom
---------                     -------
    16384                     1 file
$ unzip -l standard/achase.zip
Archive:  standard/achase.zip
TORRENTZIPPED-A4823C79
  Length      Date    Time    Name
---------  ---------- -----   ----
    16384  12-24-1996 23:32   ac.rom
---------                     -------
    16384                     1 file

The byte difference, I guess it's because of the zip comment...

so I guess both are correct in their own location, and the warning is wrong? If not, why didn't clrmame fix that? (move, delete, rename, etc.).???

Thanks!
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 86
  • Offline Offline
  • Posts: 2760
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #1 on: 15 October 2019, 07:07 »

The rom in question of the sets mf_achas and achase are identical

a800 software list:
rom name="astro chase (first star software)(1982).rom" size="16384" crc="18752991" sha1="f508b89d2251c53d017cff6cb23b8e9880a0cc0b"

standard mame:
rom name="ac.rom" size="16384" crc="18752991" sha1="f508b89d2251c53d017cff6cb23b8e9880a0cc0b" region="maincpu" offset="8000"

So most likely cmpro hits a false positive match when it tries to identify the sets.

If I remember correctly wrong system default path placements needs to be fixed manually, but in this case the original complaint about a wrong placed set is wrong...I will have a look at it later.
Logged

llagos

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 33
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.90 Chrome 77.0.3865.90
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #2 on: 15 October 2019, 14:39 »

Gracias Roman,!

In my scanner.log there are a few more:

Bristles [softwarelist: a800 - folder: bristles - size: 16kb]
wrong SysDefPath: bristles [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\a800\]

Acclaim PSX [system: Acclaim PSX - folder: coh1000a - size: 520kb]
wrong SysDefPath: coh1000a [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\coh1000a\]

Taito FX1 [system: Taito FX1 - folder: coh1000t - size: 520kb]
wrong SysDefPath: coh1000t [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\coh1000t\]

Flip and Flop [softwarelist: a800 - folder: flipflop - size: 16kb]
wrong SysDefPath: flipflop [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\a800\]

In case they are also worth looking at, to find some common root-cause...

Regards,
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 86
  • Offline Offline
  • Posts: 2760
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #3 on: 15 October 2019, 19:50 »

Hmm...I've tried to rebuild the scenario by using the MAME import and a800 as only softwarelist. Then the mentioned sets and did a scan...but no issues found. Either full or split merged. No problems here (using the latest nighly build)

So...can you provide me:

- your cmpro.ini
- your *.cmp file (cmpro's settings folder) for the used profile (I guess you're using a current official MAME binary as import)
- a pair of the archives in question (e.g. both bristles etc)...maybe the archive is special and causes a problem
« Last Edit: 15 October 2019, 20:10 by Roman »
Logged

llagos

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 33
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #4 on: 16 October 2019, 01:40 »

Hola Roman,

Here they are:
$ unzip -l wrongsysdef.zip
Archive:  wrongsysdef.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
     7711  10-15-2019 11:36   cmp/cmpro.ini
    57184  10-15-2019 11:36   cmp/settings/mame.cmp
    10087  06-15-2019 11:10   mame/roms/a800/achase.zip
    11616  06-15-2019 11:10   mame/roms/a800/bristles.zip
    12369  06-15-2019 11:10   mame/roms/a800/flipflop.zip
    10090  03-08-2017 08:08   mame/roms/standard/achase.zip
    11650  03-08-2017 08:08   mame/roms/standard/bristles.zip
    12410  03-08-2017 08:08   mame/roms/standard/flipflop.zip
   126281  03-08-2017 09:35   mame/roms/standard/coh1000a.zip
   126296  03-08-2017 09:35   mame/roms/standard/coh1000t.zip
---------                     -------
   385694                     10 files


Regarding the "systems", there are several coh.... under my "standard" folder, instead of on each swlist folder...

$ ls -l mame/roms/standard/coh1000[at].zip
-r-xr-x---+ 1 llagos None 126281 Mar  8  2017 mame/roms/standard/coh1000a.zip
-r-xr-x---+ 1 llagos None 126296 Mar  8  2017 mame/roms/standard/coh1000t.zip
$
$ ls -l mame/roms/coh1000[at]
mame/roms/coh1000a:
total 26916
drwxrwx---+ 1 llagos None        0 Oct  7 21:18 jdredd
-rwxrwx---+ 1 llagos None    45916 Sep 17 23:39 jdredd.zip
drwxrwx---+ 1 llagos None        0 Oct  7 21:18 jdreddb
-rwxrwx---+ 1 llagos None 26447098 Sep 17 23:40 nbajamex.zip
-rwxrwx---+ 1 llagos None  1061247 Sep 17 23:40 nbajamexa.zip

mame/roms/coh1000t:
total 75420
-rwxrwx---+ 1 llagos None   715161 Sep 17 23:42 ftimpact.zip
-rwxrwx---+ 1 llagos None   715161 Sep 17 23:42 ftimpactj.zip
-rwxrwx---+ 1 llagos None   715161 Sep 17 23:42 ftimpactu.zip
-rwxrwx---+ 1 llagos None 13637318 Sep 17 23:42 ftimpcta.zip
-rwxrwx---+ 1 llagos None  1500465 Sep 17 23:42 gdarius.zip
-rwxrwx---+ 1 llagos None 18006770 Sep 17 23:43 gdarius2.zip
-rwxrwx---+ 1 llagos None  1500730 Sep 17 23:43 gdariusb.zip
-rwxrwx---+ 1 llagos None   740239 Sep 17 23:43 mgcldate.zip
-rwxrwx---+ 1 llagos None 13486363 Sep 17 23:43 mgcldtex.zip
-rwxrwx---+ 1 llagos None  5683750 Sep 17 23:43 psyforce.zip
-rwxrwx---+ 1 llagos None   274288 Sep 17 23:43 psyforcej.zip
-rwxrwx---+ 1 llagos None   774692 Sep 17 23:43 psyforcex.zip
-rwxrwx---+ 1 llagos None  8266787 Sep 17 23:43 raystorm.zip
-rwxrwx---+ 1 llagos None   903870 Sep 17 23:44 raystormj.zip
-rwxrwx---+ 1 llagos None   903869 Sep 17 23:44 raystormo.zip
-rwxrwx---+ 1 llagos None   903869 Sep 17 23:44 raystormu.zip
-rwxrwx---+ 1 llagos None  5998515 Sep 17 23:44 sfchamp.zip
-rwxrwx---+ 1 llagos None   822089 Sep 17 23:44 sfchampj.zip
-rwxrwx---+ 1 llagos None   822089 Sep 17 23:44 sfchampo.zip
-rwxrwx---+ 1 llagos None   822089 Sep 17 23:44 sfchampu.zip

Best of luck!

Salu2,
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 86
  • Offline Offline
  • Posts: 2760
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #5 on: 16 October 2019, 20:12 »

- Standard folder holds a copy of "achase.zip" which is wrong. It's part of the a800 software list and should be placed in the assigned path (actually you do have a copy there, too)
- Standard folder holds a copy of "mf_achas.zip" which is wrong, too since it belongs to maxaflex bios set which is assigned to D:\games\mame\roms\maxaflex
With a clean setup profile cmpro warns me about the double set: "Set exists in various rompaths: ... " message....it does not do it with your profile though....have to check why....but generally your origiginal message is correct: wrong SysDefPath: achase [wrong: D:\games\mame\roms\standard\] [right: D:\games\mame\roms\a800\]
it found a dupe zip archive of achase there and this indeed needs to be in a800...

...and you got D:\games\mame\roms listed as a rompath, while all sets are in subpaths of that....so...this isn't a good idea either, you only need to list the real rompaths, not rompaths containing rompaths....
Logged

llagos

  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 33
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #6 on: 16 October 2019, 21:08 »

Gracias Roman,

May I ask why cmpro doesn't move these files...??? not yet implemented (in the to-do list), or just too complicated?

about "roms" folder, you're right.! didn't notice that, and probably stayed there after I moved to software lists... I just deleted it.. thanks!

Salu2,
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 86
  • Offline Offline
  • Posts: 2760
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 77.0.3865.120 Chrome 77.0.3865.120
    • View Profile
Re: wrong SysDefPath error while Scanner, but it wasn't fixed...?
« Reply #7 on: 17 October 2019, 07:41 »

Actually I have to check if an automatic move from one sysdefpath to another is implemented or not ;-) Too long ago....it's not hard to implement (acutally I think it's in...) but maybe it fails for you because you already have a copy in the right folder, too.
Logged
Pages: [1]   Go Up
 

Page created in 0.133 seconds with 22 queries.

anything
anything