EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: possible slowdown due to utf-8?  (Read 2792 times)

etabeta

  • Karma: 0
  • Offline Offline
  • Posts: 111
  • Operating System:
  • Mac OS X 10.6.3 Mac OS X 10.6.3
  • Browser:
  • Safari 4.0.5 Safari 4.0.5
    • View Profile
possible slowdown due to utf-8?
« on: 20 January 2011, 14:40 »

Hi Roman,

while rebuilding romsets using the batch run feature with MESS xml lists, I noticed that clrmame takes ages to rebuild the only two lists that contains Descriptions in Japanese text (namely, the lists fm7_cass and fm7_flop that you can find as usual at http://git.redump.net/cgit.cgi/mess/plain/hash/ ). The rebuld process takes around ~10 times more than any other list for each file. Could it be due to the presence of Japanese characters? Or shall I look elesewhere for this issue?
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 96
  • Offline Offline
  • Posts: 2915
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Chrome 8.0.552.237 Chrome 8.0.552.237
    • View Profile
Re: possible slowdown due to utf-8?
« Reply #1 on: 20 January 2011, 15:06 »

It's very unlikely that it's based on the filename...I more think your virusscanner hangs on them for whatever reason.
...but of course you can send me the files you're rebuilding....
Logged

etabeta

  • Karma: 0
  • Offline Offline
  • Posts: 111
  • Operating System:
  • Mac OS X 10.6.3 Mac OS X 10.6.3
  • Browser:
  • Safari 4.0.5 Safari 4.0.5
    • View Profile
Re: possible slowdown due to utf-8?
« Reply #2 on: 21 January 2011, 16:56 »

mind that filenames are fine (usually GAMENAME.t77 or similar, nothing exotic), the only thing that is different in those lists compared to all the other ones (which rebuild really fast) is the fact that the xml has <description> fields with Japanese characters. That's why I was wondering if that could be the reason, even if it sounded unlikely.

I'll check again tonight and try to single out a few test cases for you :)
« Last Edit: 21 January 2011, 16:57 by etabeta »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 96
  • Offline Offline
  • Posts: 2915
  • Operating System:
  • Mac OS X Mac OS X
  • Browser:
  • Safari 5.0.2 Safari 5.0.2
    • View Profile
Re: possible slowdown due to utf-8?
« Reply #3 on: 22 January 2011, 10:52 »

description isnt used for rebuilding... an easy test for you would be to simply mod the dat and replace such descriptions with something standard and rebuild again....
Logged

etabeta

  • Karma: 0
  • Offline Offline
  • Posts: 111
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.13 Firefox 3.6.13
    • View Profile
Re: possible slowdown due to utf-8?
« Reply #4 on: 27 January 2011, 06:31 »

I'm really puzzled. at the end the problem was simply that some of the files are 4MB while most of the other sets which I rebuilt together with this were <200k, so it's probably due only to the time needed to unpack-move-repack a larger file to the external HD and not to any parser problem.

sorry for the false report
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 96
  • Offline Offline
  • Posts: 2915
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Chrome 8.0.552.237 Chrome 8.0.552.237
    • View Profile
Re: possible slowdown due to utf-8?
« Reply #5 on: 27 January 2011, 08:42 »

...hmm...4MB...not that much...external HD...hmm...esata or usb?
Logged
Pages: [1]   Go Up
 

Page created in 0.095 seconds with 21 queries.