EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: 1 [2]   Go Down

Author Topic: missing roms that are not missing  (Read 9308 times)

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.71 Chrome 46.0.2490.71
    • View Profile
Re: missing roms that are not missing
« Reply #20 on: 18 October 2015, 16:59 »

hmm..ok...it seems that these roms belong to "e01s" and not "e01"

very interesting...wonder what caused this....will do some investigation...and I guess people have to find the real e01 now ;-)
« Last Edit: 18 October 2015, 17:00 by Roman »
Logged

abelenki

  • Super Drunk
  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 37
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 41.0 Firefox 41.0
    • View Profile
    • MAME Stuff
Re: missing roms that are not missing
« Reply #21 on: 18 October 2015, 17:09 »

and I guess people have to find the real e01 now ;-)
here how those sets are organized now (see screenshots with ROM name, size and CRC32).
« Last Edit: 18 October 2015, 17:11 by abelenki »
Logged
MAME favorites | Bubble Bobble Series chart / wiki | PC configuration

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.71 Chrome 46.0.2490.71
    • View Profile
Re: missing roms that are not missing
« Reply #22 on: 18 October 2015, 17:57 »

well, the funny thing is that since 162 (when mess became mame) they never changed....currently I'm checking which cmpro version was not able to find it...4.023 and 4.025 do detect it right
...maybe it was just a cache flaw....
« Last Edit: 18 October 2015, 17:58 by Roman »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.71 Chrome 46.0.2490.71
    • View Profile
Re: missing roms that are not missing
« Reply #23 on: 18 October 2015, 20:25 »

sorry...haven't found a reasonable explanation for this yet. The device sets were added in 162 and haven't changed since then. Checked some "165 locations" and they got the correct e01 and e01s sets. Same for 166. So it can't be a global problem. I don't know a reason why your e01 holds the e01s files and why older cmpro versions did not warn you.
I've tried to recreate the scenario and each version from 4.023 did find it and warned about it.

So...I can only imagine, the e01 archive was somehow replaced with e01s archive after e01 was scanned already, so it was not listed. But hell, I don't have any clue how that should happen.

If anyone got an idea or can recreate a scenario...please let me know. If anyone sees the problem, please let me know the archive date/time stamp....maybe this helps to figure out when this happend.


update...ok..had the chance to look at another backup which represents the time after .165 but before .166....and the 2 sets are still ok....so either something went weird with updating the sets with .166 or after that....
« Last Edit: 19 October 2015, 08:27 by Roman »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.71 Chrome 46.0.2490.71
    • View Profile
Re: missing roms that are not missing
« Reply #24 on: 21 October 2015, 21:17 »

ok....I found something....well...something weird...I now got it once when receiving data from the latest MAME exe that e01 was identically to e01s....(and the fixing prompts which cmpro will show are ok then....)...will do some more tests....wonder when this happens....
« Last Edit: 21 October 2015, 21:42 by Roman »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.71 Chrome 46.0.2490.71
    • View Profile
Re: missing roms that are not missing
« Reply #25 on: 21 October 2015, 21:58 »

haha...it seems that the error is within MAME...
I've created a batchfile which runs -listxml 10 times.....then I compared the output....1 out of the 10 files was different...
and guess where...exactly in the e01/e01s sets...

so it's a MAME bug...I will report this to MAMETesters.
Logged

abelenki

  • Super Drunk
  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 37
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 41.0 Firefox 41.0
    • View Profile
    • MAME Stuff
Re: missing roms that are not missing
« Reply #26 on: 22 October 2015, 02:22 »

thanks for investigation, Roman.
Logged
MAME favorites | Bubble Bobble Series chart / wiki | PC configuration

abelenki

  • Super Drunk
  • Member
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 37
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 41.0 Firefox 41.0
    • View Profile
    • MAME Stuff
Re: missing roms that are not missing
« Reply #27 on: 23 October 2015, 02:18 »

it is clear now, that the problem was MAME and not cmp, so i re-created MAME DAT with cmp20151018, and it didn't show any errors on scan, as expected. ;)
« Last Edit: 23 October 2015, 02:18 by abelenki »
Logged
MAME favorites | Bubble Bobble Series chart / wiki | PC configuration

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 46.0.2490.80 Chrome 46.0.2490.80
    • View Profile
Re: missing roms that are not missing
« Reply #28 on: 29 October 2015, 07:54 »

Hmm...either the problem is more rare than expected or they fixed it...I've run dozens of -listxml now with .167 and the e01/e01s problem did not appear.
Logged
Pages: 1 [2]   Go Up
 

Page created in 0.089 seconds with 20 queries.

anything