EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: Again CMP vs CHDs fight  (Read 2566 times)

oddi

  • Member
  • *
  • Karma: 2
  • Offline Offline
  • Posts: 178
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
Again CMP vs CHDs fight
« on: 24 April 2015, 19:07 »

Hello Roman, have again problem CMP and chd, have 3 new chds, with one have problem , other two all is fine.
Btw - i used separated folders ROMs and CHDs.
see pics

if click "Yes" cmp wanna move chd from chds folder to roms folder


when finish:


here upload full mame dat:
https://mega.co.nz/#!g8UwxYiR!imvDBStJW5-o_Ero4VvfMuYwQzq6e-zDDU0gclhW6nE

here is chd:
https://mega.co.nz/#!UsU0FI6L!Xd9N3yy2gnAG17T-PAUszepsRdseWS68FE69J57WB7g

That mame bug or ...?
Many tnx :)


« Last Edit: 24 April 2015, 19:12 by oddi »
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 87
  • Offline Offline
  • Posts: 2779
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 42.0.2311.90 Chrome 42.0.2311.90
    • View Profile
Re: Again CMP vs CHDs fight
« Reply #1 on: 24 April 2015, 20:19 »

no bug...it's only because you use a chd/rom rompath split which is nothing 'real'.

The chd in question belongs to a clone only (cloneset "tetgiano"). Since you're using full merged sets, it should be placed in the parent set (for CHDs in a folder named after the parent) "tetgiant". CMPro searches the best places for it...so it looks for the parent...and finds parts of it in your 'roms' path...

Your strict rompath split in chd-only and rom-only rompaths only exists for you, not for cmpro.

So...simply add a folder "tetgiant" in your chd path and manually move the chd in there...
Logged

oddi

  • Member
  • *
  • Karma: 2
  • Offline Offline
  • Posts: 178
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
Re: Again CMP vs CHDs fight
« Reply #2 on: 25 April 2015, 07:04 »

Roman, not luck
I try manually , auto and etc etc , cmp not like this chd, that is.
All other chds and their parents folder is fine.
Similar history from my first post.
I wanna undertand where is problem , any new mame feature or mame buggy code  again or cmp problem.

PS - CMP dont wanna this chd in my parent chds folder:
see my paths settings for Mame profile:




P.S

I stop with testing, not luck , cmp persistent move chd to ROMs folder.
dont like it :)
« Last Edit: 25 April 2015, 13:54 by oddi »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 87
  • Offline Offline
  • Posts: 2779
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 42.0.2311.90 Chrome 42.0.2311.90
    • View Profile
Re: Again CMP vs CHDs fight
« Reply #3 on: 25 April 2015, 19:26 »

Again, the fact that cmpro wants to move it to your rompath is totally normal as explained in the last post.

The idea of manually moving it to a folder (named after the parent) in your chd path is also the correct way of solving this.

However a different check (the set name check) had a little flaw and complains then about a wrong name for that newly created folder....and this should be solved with this build: http://mamedev.emulab.it/clrmamepro/binaries/cmp20150425.rar
Logged

oddi

  • Member
  • *
  • Karma: 2
  • Offline Offline
  • Posts: 178
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
Re: Again CMP vs CHDs fight
« Reply #4 on: 26 April 2015, 06:03 »

Many tnx Roman, now CMP love chd :)
Logged
Pages: [1]   Go Up
 

Page created in 0.132 seconds with 20 queries.

anything
anything