EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: wrong merging logic with new MAME builds (MESS/MAME together)  (Read 4442 times)

Mucci

  • Member
  • *
  • Karma: 22
  • Offline Offline
  • Posts: 50
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
    • MAMEGUIDE

Creating a full dat with "mame64.exe -listxml >0161r35903.xml" and scanning with CLRMAME it displays me the following error when I want to have a full merged set (Option:"Hash Collision Name"):
(using a new build that contains MAME and MESS together)

wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\drpcjr\drpcjr_bios.bin [wrong: drpcjr_bios.bin] [right: drpcjr\drpcjr_bios.bin]
wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\famitwin\rp2c33a-02.bin [wrong: rp2c33a-02.bin] [right: famitwin\rp2c33a-02.bin]
wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\m82\m82_v1_0.bin [wrong: m82_v1_0.bin] [right: m82\m82_v1_0.bin]
wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\sf7000\ipl.rom [wrong: ipl.rom] [right: sf7000\ipl.rom]
wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\omv1000\omvbios.bin [wrong: omvbios.bin] [right: omv1000\omvbios.bin]
wrong name: E:\mamesecret\MAME-ROMs\merged\MAME 0.162 ROMs\omv2000\omvbios.bin [wrong: omvbios.bin] [right: omv1000\omvbios.bin]
missing but fixable (-> omv1000) rom: omv2000\omvbios.bin [size: 16384] [CRC32: c5a67b95] [SHA1: 6d7c64dd60dee4a33061d3d3a7c2ed190d895cdb]


All of them have a parent that contains no rom or disk file (nes and sg1000 parents are empty). CLRMAME wants to put the roms in a subfolder inside the zip or in case of omv2000 in a clone. With that "correction" the are not playable.


Can you have a look at it Roman?
« Last Edit: 21 May 2015, 18:15 by Mucci »
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Mac OS X Mac OS X
  • Browser:
  • Safari 8.0 Safari 8.0
    • View Profile

do you have the files somewhere (either mame exe or listxml output) and the files (sets) listed in your post?

generally speaking, playing and validating are two things...mame should be able to lookup files in parents and subfolders....hut of course if such empty sets cause issues I will have a look...
Logged

Mucci

  • Member
  • *
  • Karma: 22
  • Offline Offline
  • Posts: 50
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
    • MAMEGUIDE
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 43.0.2357.65 Chrome 43.0.2357.65
    • View Profile

well...if you use zip files it correctly moves them to "nes", "sc3000" and "sg1000"...

With your 7z files it fails (I will look into this maybe tomorrow...but most likely because they are solid and cmpro got issues when deleting entries)....

soooo...what exactly is the problem?

edit: by the way the fixing prompts show as right place for me snes etc...for you it does not, does it? Any special settings?
« Last Edit: 21 May 2015, 21:35 by Roman »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 43.0.2357.65 Chrome 43.0.2357.65
    • View Profile

Looked at your files again...torrent7z files...

so...there you got your answer....

C:\Users\Roman>7z d -y -ms=off -mx9 E:\temp\test\drpcjr.7z drpcjr_bios.bin"
7-Zip [64] 9.38 beta  Copyright (c) 1999-2014 Igor Pavlov  2015-01-03
Error:
There is some data block after the end of the archive


and again my advice: Do not use torrent7z......
Logged

Mucci

  • Member
  • *
  • Karma: 22
  • Offline Offline
  • Posts: 50
  • Operating System:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 38.0 Firefox 38.0
    • View Profile
    • MAMEGUIDE

Thanks for your time and investigating for my problem. After all I have found out what was my problem. It was not CLRMAMEPRO and not the uploaded XML-File. The initial issue was triggered by a datfile that was missing the information regarding the empty nes, sg1000 and sc3000 folders. After creating the set with this datfile and checking with a profile created with the mame.exe within CMP, it wanted to move the files mentioned. Because I had disabled "Sets' while scanning, the information in the scan results was missing the information that the ROMs were merged to the correct folders ......

About the t7z problem: seems that 7z 9.38 beta has a bug. With 9.20 it does work.

e:\Downloads\Tets>7z d -y -ms=off -mx9 E:\downloads\Tets\drpcjr.7z drpcjr_bios.bin
7-Zip [64] 9.38 beta  Copyright (c) 1999-2014 Igor Pavlov  2015-01-03
Error:
There is some data block after the end of the archive
Not implemented
Kernel  Time =     0.000 =    0%
User    Time =     0.000 =    0%
Process Time =     0.000 =    0%    Virtual  Memory =      1 MB
Global  Time =     0.029 =  100%    Physical Memory =      4 MB

System error:
Not implemented

e:\Downloads\Tets>7z d -y -ms=off -mx9 E:\downloads\Tets\drpcjr.7z drpcjr_bios.bin
7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
Updating archive E:\downloads\Tets\drpcjr.7z
Everything is Ok
e:\Downloads\Tets>

topic closed, thanks again
« Last Edit: 23 May 2015, 07:48 by Mucci »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 106
  • Offline Offline
  • Posts: 3133
  • Operating System:
  • Mac OS X Mac OS X
  • Browser:
  • Safari 8.0 Safari 8.0
    • View Profile

ah I only used your provided mame exe not the dat since I assumed it's the direct output.
Logged
Pages: [1]   Go Up
 

Page created in 0.104 seconds with 22 queries.

anything