EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Pages: [1]   Go Down

Author Topic: [3.129] DATs with headers support bug  (Read 13998 times)

trebelez

  • Karma: 0
  • Offline Offline
  • Posts: 6
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
[3.129] DATs with headers support bug
« on: 28 July 2009, 20:11 »

Just registered to report this bug, which is happening since v3.128, I think.

Checked with No-Intro's NES, Lynx, FDS DATs. clrmamepro ask for smaller file sizes that they're supposed to be.

Hope this info is useful to you, so you can fix it.


Last, thank you so much for this great & powerful utility.
Logged


Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows Vista Windows Vista
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
Re: [3.129] DATs with headers support bug
« Reply #1 on: 28 July 2009, 20:14 »

You're sure you enabled the belonging header definition?

If yes, send me a datfile in question + the used header xml and an explanation what is reported wrong. When using header support, the sizes and checksums are from the file without the header of course.
« Last Edit: 28 July 2009, 20:39 by Roman »
Logged

trebelez

  • Karma: 0
  • Offline Offline
  • Posts: 6
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
Re: [3.129] DATs with headers support bug
« Reply #2 on: 28 July 2009, 21:03 »

You're sure you enabled the belonging header definition?

If yes, send me a datfile in question + the used header xml and an explanation what is reported wrong. When using header support, the sizes and checksums are from the file without the header of course.

Yes, its enabled at the opening of the dat, and of course re-checked by me (in Settings option) hundreds of times.

In fact, the problem is that the ROMs are recognized as 8 MB files, no matter which is the correct size, and clrmamepro ask to fix them. I tried to delete cache files and re-adding & opening the DATs, but the problem persists. They are correct with previous versions of clrmamepro, this happens just in the last two (v3.128b and v3.129).

BTW, i'm using No-Intro's headers, not the ones that came with clrmamepro.


This is a link to one log file, 3 DATs and the headers folder:
http://www.savefile.com/files/2165938
« Last Edit: 28 July 2009, 21:08 by trebelez »
Logged

Roman

  • Global Moderator
  • Member
  • ***
  • Karma: 113
  • Offline Offline
  • Posts: 3292
  • Operating System:
  • Windows Vista Windows Vista
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
« Last Edit: 28 July 2009, 22:01 by Roman »
Logged

trebelez

  • Karma: 0
  • Offline Offline
  • Posts: 6
  • Operating System:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
Re: [3.129] DATs with headers support bug
« Reply #4 on: 28 July 2009, 22:23 »

Thanks for fast replys and the solution. Have a nice day.
Logged
Pages: [1]   Go Up
 

Page created in 0.177 seconds with 19 queries.