EMULAB Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

The new forum is online, hope you enjoy it!

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - geekbrain

Pages: [1]
1
clrmame Discussion / Titles setup (non-zipped)
« on: 08 October 2023, 00:29 »
Can ClrMAME be set up to use resources that are NOT compressed (i.e. zip, rar, 7z)?  The large size of the titles.zip file took a LONG to scan and I wanted to switch to individual (*.png) files in the titles directory.  What do I change to do that?

2
I updated to version 4.038a and was able to run successfully with MAME 0.226. I tried running my Titles zip resource (from http://www.progettosnaps.net/snapshots/) and it ran for over 12 hours before I stopped thinking was hung.  Granted my machine is not the latest vintage but it never took more than a few minutes. I tried again and had the same result.  Thinking my titles.zip file was corrupt, I downloaded the base set and updates.  I cannot seem to get through a scan (with 'fix') on the base set with 0.225 dat file.  Don't know if this is a corrupt dat file, corrupt titles.zip file, or issue with ClrMAMEPro update.  I was able to scan my logos.zip file is reasonable time without issue.

Anyone have similar issue?

3
clrmame Discussion / Strange Behavior
« on: 28 July 2017, 23:54 »
Roman,
The attached log file reflects the latest 0.188 MAME with your 32 bit 4.032 code running under Win 10 (32 bit).  It is essentially a snapshot of all ROMs updated and prior to adding the updated CHDs.  It is incorrectly flagging   317-0432-jpn.data   as missing.  I tried using the rebuilder with the file and it would not rebuild.  When I finally attached the CHDs, the issue went away.  It also indicates that 3 ROMs are missing (when there are none).  I am not complaining but just simply alerting you to this strange behavior.

-Thanks-

4
clrmame Discussion / 0.182 'missing' ROM
« on: 29 January 2017, 02:19 »
Roman-
Thanks for the prompt replies on my other posts.  Are you aware of the issue on Joshi Volleyball (josvolly)?  It was discussed in the thread at:

http://www.retroroms.info/forum/topic/MAME-0-182-ROMs-sooner-arcade-mess-.htm


Quote
That's not a real new ROM, it's a rename and has the same hash info as aa003.bin, but aa008.bin has baddump status.

It's probably being rejected as a duplicate in most ROM managers.

Perhaps this will require another small update to clrmamepro?  As you can see it seems to be some kind of placeholder ROM for the 2nd MCU.  Usually when there are multiple MCUs in a game, there are separate (non-identical) ROMs for each one.  I don't know of any other games where there are identical ROMs on different MCUs, but I haven't looked for them.  I don't know what clrmamepro's proper behavior is in such a case.

<machine name="josvolly" sourcefile="gsword.cpp">
        <description>Joshi Volleyball</description>
        <year>1983</year>
        <manufacturer>Allumer / Taito Corporation</manufacturer>
        <rom name="aa003.bin" size="1024" crc="68b399d9" sha1="053482d12c2b714c23fc80ad0589a2afd258a5a6" region="mcu1" offset="0"/>
        <rom name="aa008.bin" size="1024" crc="68b399d9" sha1="053482d12c2b714c23fc80ad0589a2afd258a5a6" status="baddump" region="mcu2" offset="0"/>
</machine>


I don't know if it's real or not.

-Thanks-

5
clrmame Discussion / WWW Mode
« on: 28 January 2017, 15:45 »
I added the progettosnaps site to the Profiler WWW Mode.  I then tried to add MAMEUI's DAT files link since it is a zip file with a static name.  For some reason, CLRMamePro doesn't like MAMEUI's DAT file path (http://www.mameui.info/MameUI_DATs.zip).  Any reason I can't do this?

6
clrmame Discussion / Occasionally losing 'ROMs'
« on: 28 January 2017, 15:20 »
Every few releases, the support files (cabinets, cpanel, flyers, marquees, titles, etc.) seem to lose an entry here or there.  I think I realized what is happening.  On new releases I was doing a rebuild BEFORE scanning the pack with the new DAT file.  I suspect the rebuilding process was overwriting an entry that should have been renamed FIRST.  Can anyone confirm my suspicions?  If these suspicions are true, I can avoid doing so in the future but is there a way to alter the rebuilder to prevent others from suffering the same lapse of judgment (i.e. at least a warning)?

-Thanks-

7
clrmame Discussion / MAME Samples
« on: 30 October 2016, 21:48 »
I used the latest ClrMAMEPro (4.031b) with MAME 0.179 and noticed that with 'Samples' UNchecked it was still reporting unneeded files in the samples directory.  I thought unchecking the Samples checkbox should ignore everything to do with samples.

Pages: [1]

Page created in 0.192 seconds with 18 queries.